Tag Archives: Mailserver

Using postfix and ActiveDirectory

Quick reference for using postfix as a “shield” server to Exchange to check valid mailboxes against ActiveDirectory (SBS edition):

create a LDAP configuration file:

server_host = ad-server.your.domain
search_base = ou=MyBusiness,dc=your,dc=domain
query_filter = (&(objectClass=*) (proxyAddresses=smtp:%s))
result_attribute = sAMAccountName
bind=yes
bind_dn = dn of user account
bind_pw = pw of user

Cyrus nochmal….

Nach kurzer Umfrage auf #debian.de scheint keiner cyrus 2.1 in einer Xen3 domU auf amd64 zu benutzen, sondern nur 2.2. Nachdem ich festgestellt habe, dass der schöne Migratiosguide Mist ist und ich schon seit knapp 2h im Bett liegen könnte, läuft jetzt Cyrus 2.2 und das hoffentlich stabiler. Zumindest die Lockingfehler schien er eben schon mal besser verkraftet zu haben als der alte.

[Update]
Ja, mit locking-Problemen scheint der Gute (oder BDB 4) besser klar zu kommen. Ich habe unter anderem den minimalen Zeitabstand zwischen zwei POP3-Logins auf 5 Minuten erhöht (Falls sich jemand wundert). Bei einer Minute kommt es tlw. vor, dass der alte POP3-Prozess die Mailbox noch gelockt hat, während der neue schon versucht, darauf zuzugreifen.

Cyrus-Probleme

Ich habe jetzt das Caching von TLS-Sessions und den Duplicate-check beim IMAP/POP3-Server abgeschaltet. Dies behandelt leider nur die Symptome der kaputten Datenbanken (Amoklaufendes ctl_cyrdb, kein Login mehr möglich), aber leider nicht die Ursache. Ich hoffe trotzdem, dass der Server jetzt wieder etwas stabiler läuft…

[Update]
Haha. Statt 1x-2x pro Woche gibts jetzt alle Nase lang Probleme…

Mailserver

Mal von ein paar gelegentlichen Amokläufen des Cyrus-Wartungstools abgesehn läuft die Sache schon wieder ganz rund. Ich hoffe mal, dass die letzten Login-Probleme sich jetzt auch in Luft aufgelöst haben. Es gibt auch wieder Statistiken.
Was mir noch leichte Kopfschmerzen bereitet, sind die Mailinglisten. Mailman ist in der aktuellen Version nicht so ganz darauf ausgelegt, dass Webserver und Mailserver auf verschiedenen Rechnern laufen.

Ausgesperrt

Web.de verweigert bis auf weiteres jede EMail von uns. Ich habe eben mit dem Anti-Spam-Team Kontakt aufgenommen und hoffe, dass das halbwegs schnell wieder behoben wird.

[Update]
Das ganze war ein Konfigurationsfehler bei uns. Ich frage mich, warum das nicht auch schon bei anderen Mailservern aufgefallen ist…

[Update]
So, nun sollte es wieder gehen.

Supergau

Ok. Wir wussten, dass die Festplatte Probleme hatte. Wir planten schon lange, den etwas in die Tage gekommenen Server zu erstetzen. Auf diese Art und Weise wollten wir es allerdings nicht tun. Relativ unvorbereitet verabschiedete sich letzten Freitag die Festplatte. Friede ihrer Bits und Bytes.
Gut eine Woche nach dem Supergau funktionieren die wichtigsten Dienste wieder. Es gibt noch kleinere Probleme, welche aber eher interner Art sind, die wir aber in den nächsten Tagen auch noch in den Griff bekommen werden.

Falls sich jemand wundert: Den Mailserver erreicht man nur noch über mail.domain.tld, pop.domain.tld. imap.domain.tld, smtp.domain.tld und relay.domain.tld, aber nicht mehr wie früher über die domain selbst. Wer jetzt nicht verstanden hat, wovon ich rede, nimmt einfach mail.webstreams.de 😉
Die schlechte Nachricht: Alle Mailinglisten inklusive Mitgliedern und Archiven sind weg. Den Server werde ich in den nächsten Tagen neu aufsetzen, aber wir haben leider kein Backup und die alten Daten auf dem alten Rechner werfen mir nur noch einen “Iput/Output error” entgegen beim kleinsten versuch, sie zu kopieren.